Вайфайные заморочки (требуется помощь зала)

Тестирую тут очередную "ячеистую" Wi-Fi систему для покрытия большой площади (в данном случае это Tenda Nova MW6). Все установилось, все работает, скорости канала показывает отличные.

Локальная сеть - гигабитная. Скорость копирования с домашнего файл-сервера на компьютер - порядка 80-90 мегабайт в секунду, иногда разгоняется и до 100 мегабайт в секунду.

Теперь внимание - вопрос. К точке доступа подключаю смартфон. Он цепляется на 5 ГГц, скорость Интернета - максимальная, фактически 300 на 300 мегабит.  

Значит, скорость скачивания с файлсервера на смартфон должна порядка 20-30 мегабайт в секунду, правильно? Ставлю скачиваться файл с файлсервера на смартфон - а там вообще порядка 1 мегабайта в секунду. Я-то думаю, почему FullHD не воспроизводится и тормозит по-черному. Причем это наблюдается на разных устройствах - смартфоне и планшете.

Ну, хорошо. Подключаюсь к старой сети UniFy. Там 2,4 ГГц и скорости вот такие.

То есть ожидаемая скорость перекачки из локальной сети - где-то 5-7 мегабайт в секунду. Качаю - да, от 4 до 5 мегабайт, то есть вполне похоже на ожидаемые показатели. И FullHD воспроизводится нормально и без тормозов.

И это все - в одних и тех же условиях, UniFy и Tenda Nova подключены к одному и тому же роутеру, там все оданаковое.

Что это может быть - у кого-нибудь есть предположения? Я себе уже весь мозг сломал, все настройки перерыл. Ничего не понимаю.

Upd: Еще чудастее! Я подключил ноутбук к Nova. Тест интернет-канала выдает где-то 150 мегабит. Ну и при скачивании из локальной сети - 10 мегабайт в секунду, то есть совершенно нормальная скорость! Значит, он зарезает до 10 мегабит (1 мегабайта в секунду) только для устройств на Android! И как это, интересно, побороть?

Upd2: Пардон, всех запутал. На Windows нормальную скорость скачивания из локальной сети выдает UniFy. Novа на Windows вообще пока не дает подключиться к локальной сети, причем что ей там не нравится - непонятно совершенно. При этом на Android с ES Проводник локальную сеть видит и прекрасно подключается. Но качает очень медленно. У меня скоро  мозги вскипят.

Upd3: Подключил на Windows к локальной сети (одна неправильная настройка была, причем почему с Android работало, а с Windows нет - непонятно). Скорость под Windows - 18-20 мегабайт в секунду, это уже очень хорошо. Скорость на Android - по прежнему низкая, где-то 1,4 мегабайта в секунду. SMB протоколы на NAS настраивал, Jumbo Frame установил в минимум (пока непонятно, как вообще отключить Jumbo Frame) - не помогло. Но еще есть поле для экспериментов.

Upd3: Все, победил Android - огромное спасибо за советы, именно они и помогли! Знаете что в конце концов оказалось? На NAS надо было поддержку Samba понизить с максимальной Samba 3.0 до Samba 2.0. И тогда на Андроиде на этой сети (от чего зависит - не понимаю совершенно) поднялась скорость до 4,3 мегабайт в секунду, так что теперь FullHD нормально воспроизводится. Что и требовалось доказать. На Windows скорость так и осталась порядка 20 мегабайт в секунду. Вот ведь нетривиальная задачка была. Еще раз - всем спасибо большое. Ну и в таком виде Nova уже вполне пригодна для использования, потому что в остальном все пока вполне пристойно. Тестирую, обзор буду писать после минимум недельного использования - там еще какие-нибудь косяки могут вылезти.

07.01.2019 17:01
Комментарии 142

"И это все - в одних и тех же условиях, UniFy и Tenda Nova подключены к одному и тому же роутеру, там все одАнаковое". - Не корысти ради, просто глазастый редактор во мне проснулся.
10.01.19 09:42
0 0

На NAS надо было поддержку Samba понизить с максимальной Samba 3.0 до Samba 2.0. И тогда на Андроиде на этой сети (от чего зависит - не понимаю совершенно) поднялась скорость до 4,3 мегабайт в секунду
Возможно, потому, что на Андроид-устройствах при копировании по локальной сети всё ещё используется "устаревший" протокол Samba 2.0?
10.01.19 01:52
0 0

Не пойму, что-то тут какая-то путаница с байтами и битами. Всегда считал, что МБ/MB - это МегаБайт, а Мб/Mb - это МегаБит.
Проясните.
08.01.19 14:31
0 0

Я правильно понимаю, что это типа для домохозяек система: настроек нет, в розетку включил и всё должно сразу работать? Ну почти сразу.
08.01.19 09:38
0 0

А если самбу до 1 версии понизить.... По идее чистый протокол, без всяких заморочек. Что будет?
08.01.19 04:37
0 0

Адейтт 44. На время.
08.01.19 03:29
0 0

Upd3:
В свете вышесказанного в порядке опыта просьба потеребить Нову ай-чем_нибудь...
Интересно, в какую сторону с Яблоками качнет скорость.
Фруктолюбов в гости немало приходит в блог... 😄
08.01.19 01:18
0 0

Я пробовал на MacAir жены. Скорость была как на Windows, то есть хорошая.
08.01.19 01:53
0 0

Спасибо.
08.01.19 14:24
0 0

В итоге чем дело кончилось? Наши беляков победили, или как?
07.01.19 23:53
0 0

ну ты сам пост до конца почитай, все таки) тока там не беляки все таки, а больше желтяки)) я не расист, сразу говорю)))
07.01.19 23:55
0 0

Я тоже не расист, но тем не менее.
08.01.19 00:03
0 0

чем дело кончилось?

Ну,как всегда: китайцы-лохи, Экслер-красавчик.
08.01.19 00:19
0 0

Не красавчик, а крестьянин, который, несмотря ни на что, прорвался. С помощью мудрых советов в комментах 😄
08.01.19 02:05
0 0

в итоге, на андроиде и самбе 3.0 локалка работает на 10 мбс, на самбе 2.0 на 100 мбс. для винды вообще все равно - 1 гбс выдает на всех версиях, маку как я понял тоже до лампочки. вывод - надо каким то образом поставить на NAS самбу 4 и посмотреть что будет. это когда Алексу совсем скучно будет. Из серии как он с деревянным конструктором занимается.)))
07.01.19 23:36
0 1

Короче, я уже давно пришёл к выводу, что кому нужна гигабитная сеть, пусть тот сам с ней и кувыркается!
А тестю позавчера, вместо уже утомившего его DIR-300 (вот это уровень, это я понимаю! 😄), купил тоже давно не новый, но прямой, стабильный и проверенный SNR-CPE-W4N, от нашего отечественного (наверное, не без китайских наработок), стократнопроверенного производителя NAG! Тесть очень доволен, и ни единой пляски с бубном!
А Алексу плясать, наверное ещё не раз придётся. Работа у него такая! 😄
07.01.19 23:21
0 0

Мне гигабитная сеть очень нужна, у меня же NAS.
07.01.19 23:37
0 0

Да, всё понимаю, Алекс!
Просто я придерживаюсь довольно скептического мнения не о гигабитной сети, а именно о "полезности" формата 802.11ас. С ним полно всяких заморочек, а реальное преимущество над старым 802.11n он редко когда-либо демонстрирует. Так что переплачивать за роутеры поддерживающие формат 802.11ac считаю бесполезным выкидываем денег (для обычного комнатного пользователя). Не в вашем, конечно, случае. 😄
07.01.19 23:45
0 0

ну 5 ггц это пока все таки выход. у меня в доме сети жрут друг дружку так что кошмар, на каждом канале штук по пять. У меня 802.11n. я вынужден был с 300 мбс на принудительные 145 мбс и 20 мц ширину канала перейти, чтобы вообще что то работало. А 5 ггц при сканирование вообще чисто. как то так
07.01.19 23:52
0 0

Я не очень понимаю. У тестя двенадцатиэтажный панельный дом. Сын играет в гостях (дома конечно провод 100Мбит/с) в свою игрушку через древнейший dlink dwa-140, подключенному через 6 метров 802.11n к CPE-SNR-W4N (rev.M). Говорит, никаких тормозов (лагов/фризов) не испытывает. А он - понимает. Первый номер в мире в своей игре.
Сетей в доме - предостаточно. В вайфай аналайзере - штук 20 вылезает.
Возможно, у Вас новый комфортабельный 25-тиэтажный дом? 😄 Шучу.
08.01.19 00:03
0 0

не, я просто смотрю в спальне фильмы через plex на телеке в fullhd, через dnla. и иногда то раз в час, то каждые 5 минут безбожно фризить начинало. иногда даже на микроволновку реагировало. вот методом проб и ошибок пришел к такой конфигурации сигнала и статическом канале. А для тех требований которые у тебя, там да. там же не потоковое видео. ну может у меня слишком извращеные требования.да и лень было провода в спальню тянуть(вообще не навижу когда провода где то видно, ну а ремонт начинать не хотелось). я даже для двух приставок цифорового тв, использовал технологию EovP(через 220 вольт интернет пустил)
08.01.19 00:12
0 0

Слушайте, вот у меня тесть тоже любит трахаться (пардон за выражение) со своим "умным" телевизором! Я всегда качаю все фильмы на комп (это ж качать надо, какое безобразие, возмущается тесть) - 15 мин на пару-тройку-четвёрку фильмов, потом копирую на флешку 128ГБ USB 3.1 через USB 3.0 порт - ещё 5 мин, а потом втыкаю её в свой медиаплеер, благо телевизор у меня отнюдь не smart. И этот 802.11ac - сами понимаете где я вертел 😄 И dnla - там же 😄
08.01.19 00:19
0 0

ну каждому свое, я ж не агитирую. просто я тоже качаю на комп, но сразу много и раз в месяц. и у меня иногда фильмов под террабайт набирается. вот лежу я в кровати. по телеку ничего нет. запускаю плекс и выбираю, не вставая с кровати, что бы посмотреть или пересмотреть. мне так удобнее, чем бежать копировать на флешку. старый я, наверное, просто. ну и насчет 15 минут на 4 фильмов, тоже ой. у меня 55 телевизор, и я не люблю смотреть экранки. Я всегда жду когда релиз выйдет, и качаю хотя бы 720p. хотя стараюсь 1080, а это от 10 гигов и сильно выше. если вы 40 гигов за 15 минут скачиваете, я вам очень завидую
08.01.19 00:27
0 0

Да не, согласен, гораздо удобнее! Пусть просто сначала формат 802.11ас доработают или новый на свет произведут, или железо под него нормальное начнут выпускать и прошивки, и по приемлемой цене 25-50$. Только тогда я предпочту это ваше хвалёное удобство 😄
Экранки я тоже не смотрю. В основновном 720p (у меня 37" - разницы с 1080р ни разу не ощутил). В основном - фильмы 720р кодированные H264 весят около 3-4 ГБ. 4 фильма - 16ГБ. Скорость скачивания 100 Мбит/с или 11МБ/c. Получаем 16384/11/60 = 25 мин. Ну, чуть приврал, но не так, чтобы очень! 😄
08.01.19 00:33
0 0

ну я все это и на n добился) вроде работает пока. роутер гавкнется, буду думать. ну и на 55 уже разница сильно есть. у меня на 100 мбс на торрентах в реале редко больше 5-6 мб поднимается. все таки мы не сферический конь в вакуме)
08.01.19 00:39
0 0

Не знаю, когда один фильм качается и раздающих не менее сотни - скорость стабильная 11МБ/с. По проводу, конечно, не по хвалёному 802.11ас 😄
08.01.19 00:48
0 0

Короче, 802.11ad рулит! 😄
08.01.19 01:57
0 0

Да какое там выкидывание. У меня есть два роутера - пророссийский Tenda AC6 и прокитайский AC10 (отличаются гигабитной LAN, проц побыстрее у AC10 и прошивка у AC6 поинтереснее), стояли 1600-1800р. У обоих 11ac, якобы 300 + 867 Mbps.
10.01.19 00:53
0 0

короче я так думаю что мы все придем к мысли, что тэнда настолько нова, что очень не любит андроид и что то знает. за виндой будущее, а гуглу хана.китайцы вперед смотрят. вон скорость какая на винде)
07.01.19 23:13
0 1

скорость Интернета - максимальная, фактически 300 на 300 мегабит.

Я понимаю, что это нечестно, но тогда качать свои файлы со своего НАСа через Интернет.
Вдруг оно быстрее мегабайта пойдёт.
07.01.19 22:56
0 0

Алекс, а если взять статический айпи у провайдера, сделать в роутере проброс портов на нас, и качнуть через инет. было бы прикольно посмотреть) хотя такая схема у нас только сработает, судя какие цены на инет в европе ))
07.01.19 23:16
0 1

Алекс, а если взять статический айпи у провайдера, сделать в роутере проброс портов на нас, и качнуть через инет. было бы прикольно посмотреть) хотя такая схема у нас только сработает, судя какие цены на инет в европе ))

Имея собственный сервак, роутеру можно напарить, что на ВАН порту у него именно Интернет, а реально туда локалку сунуть.
Но это - неспортивно. Хотя может стать забавным...
07.01.19 23:33
0 0

Это читерство, но идея прикольная, спасибо 😄
07.01.19 23:37
0 0

Проброс протров - несекюрно. VPN наше все.
08.01.19 15:48
0 0

Судя по тому, что пишут на различных сайтах люди, сталкивающиеся с такой же проблемой, проблема в самом СМБ на Андроиде - точнее, я так понимаю, в настройках TCP для этого протокола (скорее всего, он просто не увеличивает window size при разгоне). Почему при этом на одной точке работает хорошо, на другой не очень - загадка. Решение не гуглится. Я бы снял дампы трафика и посмотрел на window size в одной сессии и в другой. Однако если я прав и проблема в TCP андроида - это вряд ли решается вообще хоть как-нибудь.
07.01.19 22:48
0 1

Слева -- ES File Explorer, справа Solid Explorer

Ой, апшипся, ES как раз показывает
07.01.19 22:19
0 0

Так это на каком роутере?
07.01.19 22:50
0 0

У меня проводная сеть тоже гигабитная, а роутер -- простенький, TP-Link WA901ND, но на него прошита OpenWRT. Таких роутера у меня два, в разных частях квартиры, оба имеют одинаковое имя сети и подключены к локалке проводами.

Файлы я тоже шарю по SMB.

Суть теста в том, что он показал, что разные файловые менеджеры могут показывать разную скорость в одних и тех же условиях.

Насколько я понимаю, в каждый файловый менеджер встроен свой SMB клиент и если уж подозрение пало на SMB протокол, то от клиента может что-то зависеть.

Проверил три менеджера, которые оказались у меня в телефоне, один из них скорость не показывал, а два показывали. И скорость оказалась разной, отличающейся в 1.5-2 раза. Разница стабильна, пробовал несколько раз в разном порядке, чтобы исключить возможное кеширование на SMB сервере.

Чем конкретно это вызвано -- не могу сказать.
07.01.19 23:11
0 0

У меня там все просто. Дело не в том, что они показывают, а в том, что там реально передается. На 1 мегабайт в секунду FullHD по сети не работает - тормозит по-черному. Н 4 мегабайт - работает нормально. Именно этого мне и нужно было добиться - добился в конце концов 😄
07.01.19 23:14
0 1

а ты не через dnla разве фильмы смотришь с NAS? у тебя же там и plex и аппаратная раскодировка прям в насе и вообще куча ништяков. не зря они такие деньги дерут. можеь поставь plex клиент и попробуй. будет тормозить или нет. если нет. тогда только в самбе дело. а если да. тогда все таки что то с реализацией tcp именно в паре смартфон-сервер
07.01.19 23:19
0 0

Нет, по Самба, потому что в основном смотрю с медиаплеера. А с планшета - это так, изредка. Плекс, конечно, надо будет попробовать поставить.
07.01.19 23:25
0 0

Интересно, есть ли под Андроид iperf? Было бы любопытно взглянуть. Хоть какую-то статистику по сокетам можно узнать? RTT? Packet loss?

Upd: увидел в скриншотах спидтеста. Похоже, в эту сторону можно не копать.
07.01.19 22:16
0 0

не факт. у него по интернету потерь и нет. У него проблемы с передачей файлов по локалке. а это спидтест не покажет
07.01.19 22:30
0 0

Ну, раз наружу потерь нет и RTT 18ms, то и внутри проблема явно не на уровне tcp. Похоже, правильно народ на реализацию самбы грешит.
07.01.19 22:35
0 0

тут согласен. правда еще нюанс у него локалка 1 гц приходит и торомозит при передаче до 10 мб. а на 100 мб работает. так что может что и tcp пакетами(размер например) хотя самба кажется все таки вероятнее. mtu уже уменьшали, без толку
07.01.19 22:44
0 0

Чтобы передавать 10 МБ/с при RTT 18ms, размер окна нужен - 180 КБ. Хмм. А какой размер блоков в самбе?
Я возился с iSCSI по работе, а вот с самбой не приходилось.

С другой стороны, 18мс - это наружу. Всё-таки интересно, сколько внутри.
2Алекс: попробуй хотя бы пингом померять время с сервера на телефон.
07.01.19 22:54
0 0

Блоки не в самбе, а в tcp. По умолчанию максимальное окно 65к, но сейчас на всех современных операционках (включая скорее всего и тот Линукс, поверх которого андроид работает) есть поддержка tcp опций, позволяющих увеличить окно до 4 Гб.
08.01.19 00:38
0 0

Alex, попробуй вместо ES Проводника пользоваться 😜lore. Я ушел с ES Проводника именно по этой причине - из-за глючной Samba. И тормозил он у меня, и не все файлы (папки) видел...
07.01.19 22:14
0 0

Попробовал, спасибо. Ну, кстати, разогнался аж до 2-3 мегабайт - уже хорошо. Видать все-таки все дело в реализации протокола.
07.01.19 22:55
0 0

попробуй вот эту программу поставить на планшет - 4pda.ru
07.01.19 22:05
0 0

Попробовал, спасибо. Скорость не изменилась - где-то мег в секунду при скачивании. На канале 300 на 300.
07.01.19 22:58
0 0

тогда дурдом какой то(
07.01.19 23:03
0 0

у тебя максимальная самба какой версии на NAS? - 3.0? просто сейчас уже 4.8 выпустили. может смысл есть в эту сторону рыть....
07.01.19 22:03
0 0

На NAS у меня 3.0. Так она же на том же смартфоне и том же сервере на другой сети нормально работает. В этом-то вся и проблема.
07.01.19 22:49
0 0

сейчас выходит по сути, что вся разница в роутере и 1 гигб сети на нем. роутер в винде работает прекрасно. имеет смысл поискать новее клиента для самбы?ну и скажу кощенственную вещь, может для андроида есть какие то автоматические оптимизаторы протокола tcp? на винде же полно. та программка на которую я ссылку давал, версию 4.5 поддерживает. на насе я так понимаю возможности повысить версию самба нет
07.01.19 23:00
0 0

и отключи шифрование на smb 3.
07.01.19 21:53
0 0

А какая программа делает Самба клиент на Анроиде?
07.01.19 21:48
0 0

Вас в поисковиках забанили?
ru.wikipedia.org
07.01.19 21:55
0 0

Я не спрашивал, что такое Самба, я спрашивал, какая реализация Самба клиента используется на Андроиде.
07.01.19 21:56
0 0

например вот эта 4pda.ru/forum/index.php?showtopic=833857
07.01.19 22:06
0 0

Я имел в виду, какую именно использует Алекс. Судя по скриншоту, как я теперь понял, это ES File Explorer
07.01.19 22:33
0 0

Да, у меня ES File Explorer. На другой сети он показывает вполне нормальные показатели на том же NAS.
07.01.19 22:48
0 0

ну другой сети у тебя локалка на роутер по 100 мб приходит же? а на этой по 1 гб. А это другой колленкор в характеристиках пакетов
07.01.19 22:51
0 0

Обе сети воткнуты в один и тот же роутер. Все совершенно одинаковое, в том-то и проблема.
07.01.19 23:00
0 0

Алекс, щас скажу крамольную вещь - попробуй джамбо 9000 поставить. будем играть от противного) и да, кстати на nas прошивки новой нет? все таки твоя нова это типа новье. и еще некоторые сетевые настройки применяются только при перезугрузке. в смысле та nas перегружал?
07.01.19 21:47
0 0

И да, я знаю, совет дебильный, вроде как "а принтер у вас включен", но.
Проверить ситуацию на смартфонах с разными версиями А. Чем старее, тем вернее.
07.01.19 21:45
0 0

Вместо того, чтобы молитву принести о душевной и телесной крепости (софт и хард очищающую), рождество отметить достойно, в храм сходить...
07.01.19 21:39
0 0

для контроля попробовать другие телефоны. может поможет установить причину.
07.01.19 21:14
0 0

Так это не канал. Это протокол Самбы (smb) на Андроиде тормозит. попробуй подключиться к файлсерверу через FTP или HTTP.
07.01.19 20:47
0 1

Попробую, но мне-то нужен именно Самба.
07.01.19 21:03
0 0

По крайней мере, будет известно в какую сторону смотреть.
Вот у меня сейчас схожая ситуация - с гигабитного интернета через WiFi спидтест показывает 150 мегабит, а с файл сервера, через Самбу, скачивает на 1.3 мегабайт в секунду. Внутри вся локальная сеть гигабитная.

Upd. Тот же телефон, по FTP скачивает с файл сервера на 15-18 мегабайт/сек
07.01.19 21:20
0 1

Вот у меня сейчас схожая ситуация - с гигабитного интернета через WiFi спидтест показывает 150 мегабит, а с файл сервера, через Самбу, скачивает на 1.3 мегабайт в секунду. Внутри вся локальная сеть гигабитная.
Так важный момент - скачивает под какой операционкой? У меня под Windows полная скорость, под Android сильно урезанная, под OS X - хорошая скорость.
07.01.19 22:43
0 0

У меня был случай, когда все работало, и только если файл передавался с IBM AIX определенной версии, были подобные проблемы. Был также случай, когда home router терял пакеты при подключенном к нему Mac Book. При этом с другими системами все было нормально. Разный стек TCP/IP, разные default тонкие настройки - особенно это касается окон TCP (соединение раскочегаривается на огромный размер окна, и вот тут-то начинается именно такая ситуация, как и описана - скорость падает раз в 100) и т.п. тонкостей, о которых обычно и не думаешь.
07.01.19 20:35
0 0

А с FTP сайтов нормально качает андроид?
07.01.19 20:34
0 0

Судя по каментам самый лучший solution - перестать тратить свое время на эту кривую железку и вернуть ее продавцу.
Неужели действительно не получается накрыть дом одной нормальной точкой доступа выбрав оптимальное расположение для нее? Важно чтобы сигнал в важные зоны не проходил по диагонали через толстые бетонные стены. У меня богомерзкий Airport Extreme без проблем пробивает две бетонные стены даже на 5ГГц. Если конечно дом четырехэтажный тогда наверное стоит городить огород с ячеистыми сетями.
07.01.19 20:33
0 1

Ну, тут скорее кривая не железка, а её прошивка. Алекс сейчас тратит время на то, чтобы проверить/ возможно поменять настройки своего NAS, которого у Вас, наверное нет.
Но, как мне кажется, раз UniFy работает на тех же самых настройках NAS - то дело в прошивке Tenda Nova.
Т.е., вы правы, нужно поменять железо, пока нет на него новой прошивки. Или пока откатиться на старое...

Тут три этажа. Одной точкой точно не получается. Ну и мне самому интересно найти решение и понять, что там реально работает. Эта железка очень кривая, да.
07.01.19 21:03
0 0

По идее со среднего этажа должно нормально накрывать два смежных. С учетом правильного расположения чтобы избежать диагонального прохода жб стен и перекрытий под острыми углами.
Все таки реально даже в трехэтажном доме постоянных зон, в которых реально нужно максимальное качество сигнала, раз два и обчелся: диваны, кровати, туалеты, как жеж без них 😄, ну и бассейны с зонами барбекю если уж совсем зажрался 😄
08.01.19 04:09
0 0

Прошивка как бы неотъемлемая часть железки. А то так можно считать все телефоны на квалкомм чипсете прямыми, железка то качественная. Ну а с прошивкой будем танцевать под бубен шаманов с 4pda и xda-developers, больше ведь в жизни заняться нечем.
Nas у меня действительно нет. Думал купить но понял что в моих сценариях использования он не нужен. Есть виндовый медиа-сервер, с него смотрю кино, на нем же и файловая помойка. Решил что если все устраивает то незачем усложнять. А вот пользу от недавней замены проектора на JVC я вижу в каждом просмотренном фильме, и она меня реально радует.

Попробовать с теми же настройками скачать файл на Айпад.


..что я несу.... 😒
07.01.19 19:30
0 0

Алекс, а ты же описывал, как ты настраивал файл сервер? если да, можешь дать ссылку? Посмотреть что там за настройки
07.01.19 19:19
0 0

У меня вот этот NAS. Сейчас пойду смотреть, что там на его стороне пишется.
07.01.19 19:27
0 0

настроек говоришь было на нове мало))) вот теперь есть где разгуляться))) вот это в описании - Порты Gigabit Ethernet с поддержкой Jumbo* кадров. Может эти кадры режут. Роутер их воспринимает не так support.qnap.ru
ВНИМАНИЕ! Убедитесь что ваше сетевое оборудование (роутеры, коммутаторы) поддерживают работу с Jumbo Frame!
ну и поиграйся с mtu и версией smb по ссылке
07.01.19 19:51
0 0

Точно, спасибо, я их включал, действительно.
07.01.19 19:58
0 0

Кстати, ноутбук на Windows через тот же роутер качает с сервера с нормальной скоростью. То есть получается, что проблема не в сервере, а проблема в связке Nova-Android.
07.01.19 20:04
0 0

это уже интересно... ну служебные пакеты через роутер тоже же пролетают насквозь на клиента, у андроида вполне может быть какая то антипатия к микрсофтовским улучшателям протоколов. там половина стандартов этих улучшателей и оптимизаторов, именно микрософта идея. так что я сервер бы со счетов не скидывал. Ну и еще попробуй найди устройство с 9 андроидом, помотри что будет на нем
07.01.19 20:07
0 0

Сейчас поизучаю, спасибо.
07.01.19 20:09
0 0

Кстати, ноутбук на Windows через тот же роутер качает с сервера с нормальной скоростью. То есть получается, что проблема не в сервере, а проблема в связке Nova-Android.
и опять же в той же связке интернет то у тебя летает. так что я все таки в сторону сервера склоняюсь. тут именно идея в том что пакеты с интернетом проходят без задержек. проблема именно в пакетах с сервера. структура пакетов разная. сервер что то добавляет в них, что роутер не правильно интерпретирует. и именно не правильно для андроида. если это что то исключить из пакетов, то как бы должно быть норм все. ну как то так... чисто теоретически конечно IMHO
07.01.19 20:11
0 0

кстати идея с понижением mtu очень здравая, и многое объясняет. может андроид тупо 9000 пакеты не всовывает в себя и начинает запросы посылать на уменьшение. а сколько он запросов пошлет чтобы с 9000 упасть до 1500 например, прикинь)
07.01.19 20:17
0 1

Да, очень похоже на то.
07.01.19 20:19
0 0

Для Jumbo 1500 стояло.
07.01.19 20:28
0 0

отключи джумбо. может роутер вообще не знает что такое джумбо, сообщает об этом серверу и тот передает пакеты по стандартному мту которое у него прописано. а там 9000 судя по описанию. типа низкая нагрузка не сервер и все такое. ну и поставь 1400, 1500 тоже не всегда оптимально. сейчас главное понять в чем затык, а уже потом играться можно в сторону оптимизации. слишком сильно падает скорость.
07.01.19 20:32
0 0

О! Пару месяцев назад этот Jumbo нам адски мешал. И тоже ситуация такая же, но... если клиентом был iPad! Причем, разные пробовали - проблема не конкретного девайса. С остальными - винда, Linux, MAC OS, IBM AIX - нормально. Картина была точно такая же: по тестам должно летать, при передаче большого файла - тормоза.
07.01.19 20:41
0 0

Конечно, тут явно замешана какая-то явная нелюбовь Tenda Nova к Android. На планшете всё тоже самое, Алекс?
Если письма в техподдержку ничего не решат, нужно менять роутер (временно), ждать новой прошивки или ставить на все Android устройства Windows Phone (дебильный юморок) 😄
07.01.19 19:13
0 1

Конечно, тут явно замешана какая-то явная нелюбовь Tenda Nova к Android. На планшете всё тоже самое, Алекс?
Да, в том-то и дело. Кстати, надо действительно комп с Windows подключить и проверить, минутку...
07.01.19 19:17
0 1

Алекс, кстати, "Быстрые стволы" никак не могут быть причиной? Быть может "умный Касперский"совместно с Tenda Nova пытается хоть как-то замедлить процесс Вашего растления? 😄
07.01.19 19:19
0 0

Так это же,вроде,не порно,а датская комедия? 😄
07.01.19 19:22
0 0

Да? Тогда совсем странно 😄
07.01.19 19:25
0 0

Кстати,хорошая!
07.01.19 19:27
0 0

У меня Касперский не включен.
07.01.19 19:27
0 0

Да я дуркую, пардон 😄
07.01.19 19:32
0 0

Значит, надо будет глянуть! Спасибо!
07.01.19 19:33
0 0

ПРИКОЛ! На ноутбуке (Windows 10) - 10 мегов в секунду! На Android - 1 мег в секунду. Так что действительно - проблема только с андроидными устройствами!
07.01.19 19:33
0 1

Ну, чем мог, Алекс! Хоть что-то прояснилось. Правда, до истины ещё далеко 😄
07.01.19 19:38
0 1

Да, спасибо, я сам-то не сообразил 😄
07.01.19 19:43
0 1

проблема только с андроидными устройствами!
Скорее что-то с версиями или реализацией SMB протокола. Win10 - это SMB3.0, а что там в андроиде - фиг знает.
Если инет работает нормально, то с уровнем доставки пакетов всё нормально - проблема именно в конкретном протоколе.
07.01.19 20:18
0 2

В топку!
07.01.19 19:11
0 0

кстати, а если нову принудительно в 2,4 переключить, ситуация поменяется по локалке?
07.01.19 19:01
0 0

Она не позволяет принудительно в 2,4 переключить. Но планшет подключался на 2,4 - те же сны.
07.01.19 19:05
0 0

ну собственно пройдемте:
Q 18: Can nova be modified the wireless channel?
A 18: No. In order to ensure the stability of the network, the current nova 2.4G channel is fixed to 6 channels, and the 5G is fixed to 40 channels.

Q 19: Can nova be modified wireless encryption?
A 19: No. Seamless roaming protocol requires encryption mode is WPA2-PSK, so the Nova encryption mode is fixed to WPA2-PSK.


что и требовалось доказать, нова пошла по принципу эппл, не фиг никуда лазить, мы сами все знаем за вас
07.01.19 18:36
0 0

Вот и я о том же. Браузерной админки нет, в самом приложении настройки очень примитивные.
07.01.19 18:40
0 0

Там только одно место которое можно попробовать подергать. Попробуй Qos включить. Чем черт не шутит...
07.01.19 18:46
0 0

Сразу об этом подумал и включил. Нет, не влияет. То же мегабайт в секунду, то есть 10 мбит для локальной сети.
07.01.19 18:59
0 0

Больше включать нечего там))) теперь только осталось файл сервер мучить, ну или выкинуть эту нову на фиг))) может прошивку какую выпустят
07.01.19 19:02
0 0

Зачем выкидывать? Верну обратно, это же Амазон 😄
07.01.19 19:26
0 0

попробовал бы прижать MTU на 1400 со стороны файл сервера. ( совсем не знаю как это сделать на таком сервере), если как именно это сделать не ясно, то можно попробовать временно подключить сервер кабелем из 4-х жил ( будет максимум 1500 байт жил ну и 100 мегабит) или сделать тестовый серер из виндового компа - там ясно как MTU понижать ( ну и можно дампнуть что происходит на интерфейсе, то есть оно спрашивает с такой низкой скоростью или "прорывается" очень мало ответов)
07.01.19 18:05
0 0

Пытаюсь понять, какой в этом смысл, если с того же сервера на другой точке доступа все качается с нормальной скоростью.
07.01.19 18:09
0 0

Пытаюсь понять, какой в этом смысл, если с того же сервера на другой точке доступа все качается с нормальной скоростью.
Именно в том что тенда (это предположение) криво работает с большими кадрами ETH (для гигабита 99% что включается большой размер кадра 9000, а для 100 мегабит он не может быть больше 1500)
07.01.19 18:13
0 0

Примерно такие же мысли. Очень похоже, что идут постоянные retry передачи из-за того, что по какой-то причине теряются (большие) пакеты. Т.е., оно начинает -> разгоняется, увеличивает кадр -> ошибки -> запросы re-transmission -> уменьшение кадра -> нормальный повтор -> и так по кругу. В итоге передается, но скорость на порядок-другой ниже ожидаемой.

А тесты с короткими пакетами - так и нормально.
07.01.19 18:22
0 0

У меня тоже интуиция на MTU. Почему нет проблемы с другой точкой доступа - потому что, я подозреваю, full-mesh wifi реализуется через какой-либо вид таннелинга, т.е. пакеты между нодами инкапсулируются, то есть растут в размере, что может потребовать фрагментации. С которой андроид может очень хреново справляться.

Про детали можно подумать потом (где именно низкий MTU, может на свиче....), но сначала я бы на сервере поискал настройку MSS (TCP max-segment-size). Понизить MSS до каких-нибудь 1000 и посмотреть что будет со скоростью.

Ну и если есть возможность трафик закэпчить на сервере, то тоже полезно (wireshark, tcpdump...)
07.01.19 20:27
0 0

Проверил. Для Jumbo 1500 выставлено - минимальное.
07.01.19 20:27
0 0

Тут на лицо именно 10 мбит/сек на локальном траффике.

Для проверки я бы поставил приличный свитч между основным роутером и устройствами. Те будет сеть типа модем-роутер-свитч-все остальное

Свитч естественно гигабит с принудительной скоростью на все порты. Если это сработает то нужно искать проблему в настройках интерфейса этой эйпишки.
07.01.19 18:05
0 0

Тут и стоит гигабитный свитч. К нему подключены обе точки доступа. Через одну скорость нормальная. Через эту Nova - нет.
07.01.19 18:10
0 0

Если копировать на телефон с другого компа - та же фигня? А межу двумя устройствами, подключенными к WiFi?
07.01.19 17:55
0 0

Попробуй сменить шифрование - обычно это является проблемой. На Тенде проц не очень. У меня такое было на некоторых Драйтеках
07.01.19 17:54
0 0

В первую очередь об этом подумал, но эта Nova не позволяет его поменять.
07.01.19 18:10
0 0

Тогда бы и Спидтест показывал мало...
07.01.19 21:52
0 0

вот здесь есть интересный вариант про Tenda: 4pda.ru - Роутер имеет обыкновение сбрасывать входящую скорость до 10 Мбс. Чтобы этого избежать, надо отключить у него режим a/b и оставить только N и AC.
07.01.19 17:45
0 0

Интересно, спасибо, попробую. Однако в данном случае по speedtest тут же точно не 10 Мбс 😄
07.01.19 17:47
0 0

ну тут видишь какая ситуация, на 4пда пишут, что железо откровенно слабое, и в спидтесте может показывать норм, а при нагрузке где не просто байты генерируемые пересылаются, а надо что то еще и спорта считывать, проц перегружается и лагать начинает. последнее сообще ние в данной теме, вообще прямо говорит, что tenda режет скорость в два раза из-за железа.
07.01.19 17:50
0 0

Ясно, спасибо. Но тут получается не в два раза, а раз в десять минимум.
07.01.19 17:56
0 0

у них тут есть списочек возможных вариантов. www.tendacn.com посмотри, может что не делал. Там есть не очень очевидные предложения)
07.01.19 17:38
0 0

а канал пробовал менять вручную? ну и inSSider- ом посмотри как вообще рядом обстановка в эфире. может кто из соседей перебивает
07.01.19 17:26
0 0

Он вручную менять не дает, но и на 2,4 и на 5 выбраны оптимальные каналы, это я сразу полез проверять.
07.01.19 17:30
0 0

На пятерке других устройств вообще нет.
07.01.19 17:30
0 0

ну в принципе на 5 Гц ожидаемо что никого нет. Попробуй в качестве неочевидного шага поменять режим длинного заголовка на короткого, если это есть. Ну и поотключать на пробу все встроенные средства защиты, типа файрволла, сип режима и т.д.
07.01.19 17:33
0 0

аа, и попробуй убери одновременную поддержку 20/40 Mгц ширины канала. И шифрование поменяй с tkip на aes или наоборот. У меня один раз именно из-за шифрования скорость падала
07.01.19 17:36
0 1

Пока вообще непонятно, как это сделать. У нее браузерной админки вообще нет, есть только смартфонное приложение.
07.01.19 18:08
0 0

tendawifi.com - это пробовал набирать?
07.01.19 18:15
0 0

Пробовал. Нет такого сайта.
07.01.19 18:41
0 0

Как вариант попробовать для начала подключить другой смартфон и проверить скорости на нем. Чтобы исключить сразу проблему в самом смарте и его работе с 5Ггц
07.01.19 17:23
0 0

Пробовал и смартфон, и планшет - там написано. И к 2,4 на Nova планшет подключался - та же фигня. Явно дело в точке доступа.
07.01.19 17:25
0 0
Теги
Сортировать по алфавиту или записям